eclipse启动错误Java was started but returned exit code=13解决方法

我之前正确安装并启动了eclipse
今天在运行一个古老的java程序时,
提示我使用低版本的jdk.
我安装之后,运行了低版本的java程序。
却导致eclipse不能启动。
解决方法就是重新安装对应版本的jdk,32位或64位。

我之前正确安装并启动了eclipse
今天在运行一个古老的java程序时,
提示我使用低版本的jdk.
我安装之后,运行了低版本的java程序。
却导致eclipse不能启动。
解决方法就是重新安装对应版本的jdk,32位或64位。

eclipse安装安全警告

错误提示是:
Warning: You are installing software that contains unsigned content.The authenticity or validity of this software cannot be established. Do you want to continue with the installation?
这是常规的安全警告,点Install anyway继续安装即可。

错误提示是:
Warning: You are installing software that contains unsigned content.The authenticity or validity of this software cannot be established. Do you want to continue with the installation?
这是常规的安全警告,点Install anyway继续安装即可。

eclipse常用环境设置

主要配置内容如下:
编码集:UTF-8
内容自动提示:Content Assist
jsp默认的编码集:ISO 10646/Unicode(UTF-8)
外部浏览器:谷歌chrome
代码模板的构建
快捷键配置
配置类注释模板和方法注释模板
背景颜色配置
字体大小设置
去掉类名或者接口名前自动添加上的包名
设置不格式化注释
配置maven仓库
设置tab键为4个空格,统一格式

主要配置内容如下:
编码集:UTF-8
内容自动提示:Content Assist
jsp默认的编码集:ISO 10646/Unicode(UTF-8)
外部浏览器:谷歌chrome
代码模板的构建
快捷键配置
配置类注释模板和方法注释模板
背景颜色配置
字体大小设置
去掉类名或者接口名前自动添加上的包名
设置不格式化注释
配置maven仓库
设置tab键为4个空格,统一格式

Eclipse Java IDE与EE IDE工具区别(ide for Enterprise java developers)

Eclipse Java IDE (轻量级,初学)
默认只带了 GUI 和 swings 的库,但是并不支持 web 及数据库开发。
Eclipse Java EE IDE (企业版、web开发)
EE 代表 Enterprise Edition– 企业版本
预装了几乎所有插件,可以开发 HTML, JSP, Javascript 等,即支持 web 及数据库开发。
所以如果需要使用 Spring 开发,应该选择 Eclipse Java EE IDE。

Eclipse Java IDE (轻量级,初学)
默认只带了 GUI 和 swings 的库,但是并不支持 web 及数据库开发。
Eclipse Java EE IDE (企业版、web开发)
EE 代表 Enterprise Edition– 企业版本
预装了几乎所有插件,可以开发 HTML, JSP, Javascript 等,即支持 web 及数据库开发。
所以如果需要使用 Spring 开发,应该选择 Eclipse Java EE IDE。