解决Could not find a version that satisfies the requirement xxx (from versions: )

今天安装Django 2.2提示如下错误:

  Could not find a version that satisfies the requirement Diango==2.2 (from versions: )
No matching distribution found for Diango==2.2
You are using pip version 18.1, however version 19.0.3 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.

很多时候很纠结,安装最新版本的python,可能有些源码不兼容。
不安装最新版本,又提示你升级。


一.环境

使用python3.7时,用pip安装openpyxl出现如下错误:

系统环境:windows10家庭版
Python版本:python3.7.1
IDE:sublime_text 3

二. 解决方案

按照提示所示是其中一个原因是pip版本过低,需要更新pip:
python -m pip install –upgrade pip
由于python国内网络不稳定,一直报错,升级了很多次才成功。

然后继续还是报错:

可能考虑到是python国内网络的问题,这时我们用国内的镜像源来加速。
pip install 包名 -i http://pypi.douban.com/simple/ –trusted-host pypi.douban.com
这个是豆瓣源

–trusted-host pypi.douban.com 这是为了获得ssl证书的认证,要不然会报错

然而还是报错,可能是我电脑网络原因,常理来说都可以安装成功的,大家到这一步可能应该已经解决问题了。

我最后还是用pip3 install openpyxl尝试很多次后才安装成功。

三. pip和pip3的区别
其实这两个命令效果是一样的,没有区别:

比如安装库openpyxl,pip3 install openpyxl或者pip install openpyxl:只是当一台电脑同时有多个版本的Python的时候,用pip3就可以自动区分用Python3来安装库。是为了避免和Python2发生冲突的。
(2)如果你的电脑只安装了Python3,那么不管用pip还是pip3都一样的。
安装了python3之后,会有pip3
(1)使用pip install XXX :
新安装的库会放在这个目录下面:python2.7/site-packages
(2)使用pip3 install XXX :
新安装的库会放在这个目录下面:python3.7/site-packages

(3)如果使用python3执行程序,那么就不能importpython2.7/site-packages中的库。


解决’python -m pip install –upgrade pip’ 报错问题

再安装包的时候提示

You are using pip version 9.0.3, however version 10.0.1 is available.<br>
You should consider upgrading via the 'python -m pip install --upgrade pip' command.12

而我按照要求运行python -m pip install –upgrade pip 后仍然无法成功升级,提示如下:

(venv) D:\Fish>python -m pip install --upgrade pip<br>
Requirement already up-to-date: pip in d:\fish\venv\lib\site-packages (10.0.1)12

于是按照要求将d:\fish\venv\lib\site-packages (10.0.1) 中的pip-10.0.1.dist-info删除,再次运行python -m pip install –upgrade pip 后升级成功,之前不能安装的包也能安装了!

作者:

喜欢围棋和编程。

 
发布于 分类 编程标签

发表评论

电子邮件地址不会被公开。